Close

Results 1 to 18 of 18
  1. #1
    Join Date
    Feb 2010
    Posts
    616
    Rep Points
    629.9
    Mentioned
    0 Post(s)
    Rep Power
    7


    Reputation: Yes | No

    Airmatic Question

    Seriously, the constant changing of height on my car is about to drive me over the edge. Yesterday the stance was perfect, then this morning the back has lowered enough that my tires are rubbing over bumps. I have had the system checked and rechecked and there aren't any issues. We re-wired my Renntech ELM and the car stayed pretty much the same height for a couple months, but now it is back to fluxuating. Could it be a bad ELM? Thoughts or ideas?

  2. #2
    Join Date
    Jan 2010
    Location
    SoCal
    Posts
    117,712
    Rep Points
    31,536.5
    Mentioned
    2064 Post(s)
    Rep Power
    316


    Reputation: Yes | No
    Let me help you move this to the proper section Click here to enlarge Chassis, suspension, etc., goes in the forum section for the Mercedes class. In this case, E-class, W211.

    I hate to through every suspension question at Matt@Camber-Toe, but that is what I recommend here. Send him a pm or ask him to chime in on this thread as he would be the guy to ask.

  3. #3
    Join Date
    Feb 2010
    Posts
    616
    Rep Points
    629.9
    Mentioned
    0 Post(s)
    Rep Power
    7



    Reputation: Yes | No
    Gdamn Sticky..this stuff is confusing. Us MB owners can't figure all this crap out.Click here to enlarge

  4. #4
    Join Date
    Jan 2010
    Location
    SoCal
    Posts
    117,712
    Rep Points
    31,536.5
    Mentioned
    2064 Post(s)
    Rep Power
    316


    Reputation: Yes | No
    Click here to enlarge Originally Posted by 930chas Click here to enlarge
    Gdamn Sticky..this stuff is confusing. Us MB owners can't figure all this crap out.Click here to enlarge
    Hahahhaha.

    Honestly, I'm starting to think for you guys there just needs to be one forum section titled, "MERCEDES OWNERS POST HERE."

    Engine and Performance sections are for discussing the engine, tuning, etc, and the chassis/class sections are for suspension, brakes, interior, electronics, etc., specific to that class. You'll get the hang of it Click here to enlarge

  5. #5
    Join Date
    Feb 2010
    Location
    Hanover, MD
    Posts
    1,220
    Rep Points
    697.0
    Mentioned
    4 Post(s)
    Rep Power
    7


    Reputation: Yes | No
    The humorous part is how everything starts organized and then goes OT within the first page.

    With that said, is there a good indy Merc shop that is active on any of the forums? I get to play with the wife's R170 climate control today
    Click here to enlarge

  6. #6
    Join Date
    Jan 2010
    Location
    SoCal
    Posts
    117,712
    Rep Points
    31,536.5
    Mentioned
    2064 Post(s)
    Rep Power
    316


    Reputation: Yes | No
    Click here to enlarge Originally Posted by SSDD Click here to enlarge
    With that said, is there a good indy Merc shop that is active on any of the forums?
    I can't really suggest one for your location.

  7. #7
    Join Date
    Jan 2010
    Location
    SoCal
    Posts
    117,712
    Rep Points
    31,536.5
    Mentioned
    2064 Post(s)
    Rep Power
    316


    Reputation: Yes | No
    Click here to enlarge Originally Posted by SSDD Click here to enlarge
    The humorous part is how everything starts organized and then goes OT within the first page.
    That's our thing Click here to enlarge

    Makes for interesting reads, you never know what you will get.

  8. #8
    Join Date
    Aug 2010
    Location
    Valley Stream NY
    Posts
    3,301
    Rep Points
    2,757.2
    Mentioned
    85 Post(s)
    Rep Power
    28


    1 out of 1 members liked this post. Reputation: Yes | No
    Are you sure you don't have a leak in one of the bags?

    Is the pump overheating from running too long, causing it to time out even with the suspension still at improper ride height?

    I'd check the wiring on the pump just to be sure....they were known to melt the connectors or corrode them in the plastic holder that connects it to the pump.

    All else fails you might have a bad level sensor or the ELM module is no good.

  9. #9
    Join Date
    Jan 2010
    Location
    SoCal
    Posts
    117,712
    Rep Points
    31,536.5
    Mentioned
    2064 Post(s)
    Rep Power
    316


    Reputation: Yes | No
    ^ Thank you Matt, can always count on you.

  10. #10
    Join Date
    Aug 2010
    Location
    Valley Stream NY
    Posts
    3,301
    Rep Points
    2,757.2
    Mentioned
    85 Post(s)
    Rep Power
    28


    1 out of 1 members liked this post. Reputation: Yes | No
    I wanted to mention to also check the distribution block next to the pump. I've seen those get stuck solenoids or leak internally.

  11. #11
    Join Date
    Feb 2011
    Posts
    33
    Rep Points
    29.0
    Mentioned
    1 Post(s)
    Rep Power
    0


    1 out of 1 members liked this post. Reputation: Yes | No
    I hate to say it Charlie but I have the Renntech ELM V2 and the CLS never changes stance. My 04 E55 never did either unless of course it was on un even ground and then it seemed to try and adjust for that. But in the flat garage, never.

  12. #12
    Join Date
    Feb 2011
    Posts
    50
    Rep Points
    37.9
    Mentioned
    0 Post(s)
    Rep Power
    0


    Reputation: Yes | No
    I'm gonna have to think it's that ELM Charlie. My car never changes height. I would change out the cheapest thing first and see if that helps, but that ELM might be on it's way out. Click here to enlarge
    Click here to enlarge

  13. #13
    Join Date
    Feb 2011
    Posts
    8
    Rep Points
    5.7
    Mentioned
    0 Post(s)
    Rep Power
    0


    Reputation: Yes | No
    Just go coil-overs and be done Click here to enlarge

    Someone has be......

  14. #14
    Join Date
    Feb 2010
    Posts
    616
    Rep Points
    629.9
    Mentioned
    0 Post(s)
    Rep Power
    7



    Reputation: Yes | No
    Thanks much for all the advice. I tend to think it is the ELM also. We have tested every part of the factory system and can't find any issues. Plus with a slow leak I would expect it to settle when the car sat for a week or two, and it doesn't. Damn, I will be a happy mofo to have this car stay at my selected stance!

    If I ever have a serious airmatic issue, I will definitely tackle the coil-overs.

  15. #15
    Join Date
    Jan 2010
    Location
    SoCal
    Posts
    117,712
    Rep Points
    31,536.5
    Mentioned
    2064 Post(s)
    Rep Power
    316


    Reputation: Yes | No
    ^ Update us with what you intend to do.

  16. #16
    Join Date
    Feb 2010
    Posts
    616
    Rep Points
    629.9
    Mentioned
    0 Post(s)
    Rep Power
    7



    Reputation: Yes | No
    Replace my pos ELM with another one for right now.

  17. #17
    Join Date
    Feb 2011
    Posts
    50
    Rep Points
    37.9
    Mentioned
    0 Post(s)
    Rep Power
    0


    Reputation: Yes | No
    Click here to enlarge Originally Posted by 930chas Click here to enlarge
    Replace my pos ELM with another one for right now.
    Are you going to use another Renntech unit? If so what version?
    Click here to enlarge

  18. #18
    Join Date
    Feb 2010
    Posts
    616
    Rep Points
    629.9
    Mentioned
    0 Post(s)
    Rep Power
    7



    Reputation: Yes | No
    Click here to enlarge Originally Posted by tgoss Click here to enlarge
    Are you going to use another Renntech unit? If so what version?
    I guess v2. Is that what you have? What are your thoughts?

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •