Close

Results 1 to 15 of 15
  1. #1
    Join Date
    May 2010
    Posts
    740
    Rep Points
    453.1
    Mentioned
    0 Post(s)
    Rep Power
    5


    1 out of 1 members liked this post. Reputation: Yes | No

    My first track experience..

    Well the lime green M3 got some track time today. I attended the "Red meat and race fuel" day at MSR Houston. http://www.msrhouston.com

    I was running late so I didn't have a chance to grab my video camera.. but I will next time.

    The car ran great, no major heat soak issues with the VF kit and my oil/water temps seemed to be running quite cool considering the 90+ temps outside. The car is a rocket.. a bit more power than I expected considering this is the first time I have really pushed the car out of turns etc..

    I'm hoping some folks will post pictures of the event on the Texasmotorevents.com web site. I barely got there in time to make the first DE group.

    What I learned today was no matter how much horsepower you have.. your driving skill is what matters most. I was passed quite embarrassingly... in a turn.. by of all things a Dodge Neon Click here to enlarge

    Of course it was a full blown track car lol..

    I am hoping to take their driving course soon and start upping my skill level. I'll be sure to take pics/video next time I'm there.

    Click here to enlarge

  2. #2
    Join Date
    Jan 2010
    Location
    SoCal
    Posts
    117,838
    Rep Points
    31,573.4
    Mentioned
    2066 Post(s)
    Rep Power
    316


    Reputation: Yes | No
    Pics and vids would be badass but that looks like a nice sized track with nothing to run into if you make a mistake.

    If you can run in heat in Texas you can run anywhere, impressive.

  3. #3
    Join Date
    May 2010
    Posts
    740
    Rep Points
    453.1
    Mentioned
    0 Post(s)
    Rep Power
    5



    Reputation: Yes | No
    Click here to enlarge Originally Posted by Sticky Click here to enlarge
    Pics and vids would be badass but that looks like a nice sized track with nothing to run into if you make a mistake.

    If you can run in heat in Texas you can run anywhere, impressive.
    Here is a better picture of the track.. it was a really tough track... One could easily reach 150 on the back straight with a high HP car.

    Click here to enlarge

  4. #4
    Join Date
    Jan 2010
    Location
    SoCal
    Posts
    117,838
    Rep Points
    31,573.4
    Mentioned
    2066 Post(s)
    Rep Power
    316


    Reputation: Yes | No
    ^ Do you know the length of the straight by any chance?

  5. #5
    Join Date
    May 2010
    Posts
    740
    Rep Points
    453.1
    Mentioned
    0 Post(s)
    Rep Power
    5



    Reputation: Yes | No
    Click here to enlarge Originally Posted by Sticky Click here to enlarge
    ^ Do you know the length of the straight by any chance?
    I sure don't.. there are a number of videos on Youtube.. use search "MSR Houston"

  6. #6
    Join Date
    May 2010
    Location
    SoCal
    Posts
    2,266
    Rep Points
    936.0
    Mentioned
    5 Post(s)
    Rep Power
    10


    Reputation: Yes | No
    what did you hit on the straight?
    Click here to enlarge

  7. #7
    Join Date
    May 2010
    Posts
    740
    Rep Points
    453.1
    Mentioned
    0 Post(s)
    Rep Power
    5



    Reputation: Yes | No
    Click here to enlarge Originally Posted by Yukohama Click here to enlarge
    what did you hit on the straight?
    Around 120 or so. I wasn't pushing the car hard. I figure I could probably reach 130-135 pushing it real hard. The real track cars out there can hit 150 pretty easy. It's a decent straight.

  8. #8
    Join Date
    Jun 2010
    Posts
    86
    Rep Points
    75.6
    Mentioned
    0 Post(s)
    Rep Power
    0


    Reputation: Yes | No
    Nice bud, did you run it clockwise or counter clockwise?

  9. #9
    Join Date
    May 2010
    Posts
    740
    Rep Points
    453.1
    Mentioned
    0 Post(s)
    Rep Power
    5



    1 out of 1 members liked this post. Reputation: Yes | No
    Click here to enlarge Originally Posted by Sticky Click here to enlarge
    Pics and vids would be badass
    Here are some pics..

    Click here to enlarge
    Click here to enlarge
    Click here to enlarge

  10. #10
    Join Date
    Apr 2010
    Location
    Earth
    Posts
    5,159
    Rep Points
    526.1
    Mentioned
    4 Post(s)
    Rep Power
    6


    Reputation: Yes | No
    Awesome dude. Are you running a stock radiator?
    Click here to enlargeClick here to enlarge

  11. #11
    Join Date
    May 2010
    Posts
    740
    Rep Points
    453.1
    Mentioned
    0 Post(s)
    Rep Power
    5



    Reputation: Yes | No
    Click here to enlarge Originally Posted by mpoweroo1 Click here to enlarge
    Nice bud, did you run it clockwise or counter clockwise?
    We ran it clockwise

  12. #12
    Join Date
    May 2010
    Posts
    740
    Rep Points
    453.1
    Mentioned
    0 Post(s)
    Rep Power
    5



    1 out of 1 members liked this post. Reputation: Yes | No
    Click here to enlarge Originally Posted by GG///M3 Click here to enlarge
    Awesome dude. Are you running a stock radiator?
    running a Zionsville radiator, 55 stat and replaced the AUX fan with a Spal. I'm also running a Setrab oil cooler.

    Click here to enlarge

  13. #13
    Join Date
    Jan 2010
    Location
    SoCal
    Posts
    117,838
    Rep Points
    31,573.4
    Mentioned
    2066 Post(s)
    Rep Power
    316


    Reputation: Yes | No
    You have a beautiful engine bay.

  14. #14
    Join Date
    May 2010
    Posts
    740
    Rep Points
    453.1
    Mentioned
    0 Post(s)
    Rep Power
    5



    Reputation: Yes | No
    Click here to enlarge Originally Posted by Sticky Click here to enlarge
    You have a beautiful engine bay.
    Thanks.. went to a local met tonight that was having dyno pulls. Decided what the hell and stuck my car on the dyno. It was a Mustang dyno, I'd never been on one before. Anyway's, they didn't hook up any signal wire or anything, everything was done via the rollers??

    Car was way down on power, only did a little over 400 WHP. I was on race fuel so it should have been near 500. My Dynojet on 104 was 503/333.

    Anyways, I have some issues to trouble shoot looks like. I have had the new version 3 Alpha N tune flashed from GIAC, replaced the alternator, new battery and installed my direct port meth since my last dyno session. I'm going to need to do another dynojet session with boost/afr readings to see if I have any boost leaks, belt slip etc.. before I pass judgment on the tune being the culprit I need to check my work on the alternator swap to make sure I didn't miss something.

    Once I have had a chance to adequately trouble shoot I'll let you guys know what I find. I'm hoping to have OE tuning do my car here pretty soon so I may just make sure my install is sound.

  15. #15
    Join Date
    Nov 2009
    Location
    USA
    Posts
    2,215
    Rep Points
    1,142.0
    Mentioned
    11 Post(s)
    Rep Power
    12


    Reputation: Yes | No
    Ah! Missed this! I was stuck at work. Either way, MSR is pretty sick. Have you seen their karting days? those are pretty ridiculous too.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •