Close

Results 1 to 4 of 4
  1. #1
    Join Date
    Feb 2010
    Location
    Corpus Christi, Texas, United States
    Posts
    3,106
    Rep Points
    1,236.6
    Mentioned
    6 Post(s)
    Rep Power
    13


    Yes Reputation No

    Cool 361 Motorsports @ PRI

    Just wanted to make a Picture/Video thread of some stuff I took at Performance Racing Industries trade show in Orlando, Florida. We operated the outside Exhibit for Mustang Dynamometers using our mobile AWD-500 dyne.

    It was a 20 hour straight-through drive for us, and a ton of fun!

    Also, I recommend going to the Brickhouse bar and getting a Kobe Burger, rare, with 20oz of Yuengling on tap.

    I got to meet people from Borg Warner and play with the new EFR turbos in person..... can't wait to use that tech. Click here to enlarge


    I'll let the pictures speak:

    Click here to enlarge
    Click here to enlarge
    Click here to enlarge
    Last edited by fundahl; 12-21-2011 at 12:51 PM.

  2. #2
    Join Date
    Jan 2010
    Location
    SoCal
    Posts
    119,425
    Rep Points
    32,105.3
    Mentioned
    2106 Post(s)
    Rep Power
    322


    Yes Reputation No
    What were the uploading issues?

  3. #3
    Join Date
    Feb 2010
    Location
    Corpus Christi, Texas, United States
    Posts
    3,106
    Rep Points
    1,236.6
    Mentioned
    6 Post(s)
    Rep Power
    13



    Yes Reputation No
    Click here to enlarge Originally Posted by Sticky Click here to enlarge
    What were the uploading issues?
    I've tried uploading from url, computer, facebook, it just won't work. The pictures are compressed and within limit. I don't know why it's doing this, I've never had an issue before.

  4. #4
    Join Date
    Jan 2010
    Location
    SoCal
    Posts
    119,425
    Rep Points
    32,105.3
    Mentioned
    2106 Post(s)
    Rep Power
    322


    Yes Reputation No
    Click here to enlarge Originally Posted by SlicktopTTZ Click here to enlarge
    I've tried uploading from url, computer, facebook, it just won't work. The pictures are compressed and within limit. I don't know why it's doing this, I've never had an issue before.
    The pics are displaying...

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •