Close

Results 1 to 4 of 4
  1. #1
    Join Date
    Dec 2010
    Posts
    2,157
    Rep Points
    -11.0
    Mentioned
    21 Post(s)
    Rep Power
    0


    Reputation: Yes | No

    Bad Kleeman CLK Supercharger Install by Motorwerks of Houston

    1st off the owner Sunil is my friend; however, I had a bad experience with my 2004 CLK55 Kleemann Build as follows: (the short version)

    Drop car off Sept 2010 for Kleemann Blower install, p/p heads, cams, headers, tune, paint.

    Pick car up Feb 2011:
    Car is filthy, seat bolster damaged, headliner greased up, air vent broken
    Car barely starts, and is on empty.
    Drive 1 mile to shell station, car will not restart.
    A few select words later, car barely starts.
    On way home notice bad drivability, shuddering shifting, etc....
    Pop the hood open at the house and notice blower belt pulley misaligned by 1/8", random vac lines disconnected, and generally poor workmanship.
    I pop in a new battery which solves the hard to start issue.
    The next day I go out for a quick run to see what I have, and accy/blower belt shreds off @ 70mph. Limp to a side road and tow to the shop for attempt #2.

    Back at shop, they fix the water pump they broke while tapping for the kleemann pulley which they claim caused the mis-alignment, plus modfied the blower pulley..... clean the car.
    I come back 1.5 months later to p/u the 2nd time:
    Drive car home, still bucking on shifts, and now random "take car to shop" warnings on the dashboard indicator.
    After closer inspection I find more issues:
    * heat exchanger not attached to anything.. just sitting on lower valence.
    * he line leaking
    * fuel inj not properly seated (orings showing), and not lined up right
    * he pump wiring exposed
    * y-pipe broken and not sealed to mass air meter
    * shoddy exhaust work... painted welds with bbq pit paint!!!!
    * The big one... kleemann USA found one of the cams was installed a tooth off..... causing my crap idle....... WTF?.....
    * Valve cover gaskets leaking
    * Blower not sealing to heads due to hitting a bracket not ground off completely.
    * rad shroud gutted to install the he..... just wacked it off....
    * random clips/mb fasteners broken or missing
    * PTE thermostat not installed.....
    * oil catch can not installed......
    * unable to produce a dyno sheet for my dyno work or tune......

    Car is currently at Kleemann USA in Co getting sorted out by the experts. They advised that this workmanship would not pass at a local highschool shop class.

    Do your homework before getting work done on your expensive/exclusive mb product.

    Cheers,
    Jeff Houston

    original source: http://w209forums.com/showthread.php...BAD-Experience

  2. #2
    Join Date
    Apr 2011
    Location
    Newport Beach, CA
    Posts
    20
    Rep Points
    85.9
    Mentioned
    0 Post(s)
    Rep Power
    0


    Reputation: Yes | No
    Click here to enlarge Originally Posted by blkclk550 Click here to enlarge
    Car barely starts
    Huh?


    Click here to enlarge Originally Posted by blkclk550 Click here to enlarge
    Do your homework before getting work done.

  3. #3
    Join Date
    Dec 2010
    Posts
    2,157
    Rep Points
    -11.0
    Mentioned
    21 Post(s)
    Rep Power
    0



    Reputation: Yes | No
    Click here to enlarge Originally Posted by splinter Click here to enlarge
    Huh?
    are you lost my friend?

  4. #4
    Join Date
    Jan 2011
    Posts
    143
    Rep Points
    313.0
    Mentioned
    6 Post(s)
    Rep Power
    4


    Reputation: Yes | No
    That is a simply shocking story, good luck with getting car in working order

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •