Close

    • Trouble in paradise? Vishnu/FFtec N54 335ii Single Turbo kits experiencing issues as a BimmerBoost member runs 12.5@121 with misfires and having to short shift

      BimmerBoost would like to thank member GeorgiaTech335Coupe for his openness and honesty regarding his Vishnu/FFTEC single turbo setup. Recently, this member took his single turbo upgraded 6-speed manual 335i to the PBIR (Palm Beach International Raceway) dragstrip in Florida to do some testing. His best run was a 12.50@121.6 alongside a 12.8@117. Yes, these times are quite a ways away from the 10.8@131 glory pass from Vishnu demonstrating the kits capability.


      This is in no way the fault of GeorgiaTech335Coupe who experienced misfires on his car and had to short shift at 6300 rpm in order to avoid them. Now, Vishnu has basically portrayed this kit as perfect and ready for sale with nobody having any issues. The reason BimmerBoost is bringing this issue to the attention of the community is for potential buyers to understand what they are getting into.


      There is absolutely nothing wrong with having issues when modifying a car to this level and BimmerBoost is confident Vishnu will resolve them. There is something wrong with pretending nothing is wrong. A few cars with the single turbo kits have gone up for sale and apparently a total of three people, that are willing to open their mouths, are having misfire issues with these kits.

      These issues will no doubt get resolved but potential buyers and current customers needs to be aware of the process, effort, and that progress is being made. Pretending nothing is wrong and collecting money simply is the wrong way to go about this and once again (it's becoming a trend) BimmerBoost is the only site bringing these issues to the attention of the community.

      For the record, a member by the name of @tmo335tt says he has a hardware solution for the misfires that he will likely share with Vishnu (hopefully not for free). Interesting that it isn't Vishnu but the community solving this.

      Thanks again to @GeorgiaTech335Coupe for sharing his details, good or bad, as we all learn thanks to honesty and openness. There is more to tuning than just collecting money.

      This article was originally published in forum thread: Vishnu Single Turbo at PBIR - 12.50@121.6 having to shift all gears at 6300rpm started by Sticky View original post
      Comments 1090 Comments
      1. LostMarine's Avatar
        LostMarine -
        Click here to enlarge Originally Posted by GeorgiaTech335Coupe Click here to enlarge
        Not my data, so I don't have access to it.

        When I get around to it, I'll do some 60-130 runs. I'll do some with and without NLS too so we can see what the difference is.
        well, it would have been nice to see the comparison prior to debating it, as it reduces validity through bias. not that im accusng, but it will now have that stigma.
      1. GetSomeE92's Avatar
        GetSomeE92 -
        Click here to enlarge Originally Posted by GeorgiaTech335Coupe Click here to enlarge
        I'd gladly let an AT owner take my car down the strip once this weekend in Orlando to see how much fun it is trying to launch this car.
        I'll take you up on that offer if you end up going to the PBIR event on Jan. 27. Click here to enlarge
      1. GeorgiaTech335Coupe's Avatar
        GeorgiaTech335Coupe -
        So far very uneventful. I haven't been able to get any traction in 1st or 2nd. Just goes straight to redline. Not 1 clean pass yet. Track prep is very bad. Best trap so far is a little over 122, but that isn't on a clean run. Also, sometimes I'm getting a misfire on cylinder 3 at redline. I think I have a bad coil. I'm still running so hopefully I can get at least 1 clean run. Otherwise that's $213 down the drain for track fee.
      1. LostMarine's Avatar
        LostMarine -
        Click here to enlarge Originally Posted by GeorgiaTech335Coupe Click here to enlarge
        So far very uneventful. I haven't been able to get any traction in 1st or 2nd. Just goes straight to redline. Not 1 clean pass yet. Track prep is very bad. Best trap so far is a little over 122, but that isn't on a clean run. Also, sometimes I'm getting a misfire on cylinder 3 at redline. I think I have a bad coil. I'm still running so hopefully I can get at least 1 clean run. Otherwise that's $213 down the drain for track fee.
        Sucks, let us know how it goes. any vids yet?
      1. GeorgiaTech335Coupe's Avatar
        GeorgiaTech335Coupe -
        Click here to enlarge Originally Posted by LostMarine Click here to enlarge
        Sucks, let us know how it goes. any vids yet?
        None yet. I have my gopro but not really worth doing until I can run the car respectably.
      1. Terry@BMS's Avatar
        Terry@BMS -
        Swap the coil over to say #1 to see if the misfire moves with it.
      1. GeorgiaTech335Coupe's Avatar
        GeorgiaTech335Coupe -
        Something else isn't right with my car. FP voltage is all over the place, bank 1 AFR and STFt are all over the place. I can feel the car making weird hiccups during the pull. This really sucks. I'm beginning to lose my patience trying fix this car.
      1. Q4P's Avatar
        Q4P -
        u running slicks? According to Shiv that is what is needed to run 10's in this very streetable car lol...
      1. GeorgiaTech335Coupe's Avatar
        GeorgiaTech335Coupe -
        For reference, there was a stock 2013 GT500 that was trapping between 125-127.
      1. RnmEvo9's Avatar
        RnmEvo9 -
        Click here to enlarge Originally Posted by GeorgiaTech335Coupe Click here to enlarge
        For reference, there was a stock 2013 GT500 that was trapping between 125-127.
        Thats what they generally trap. Damn, GT500 is sounding more appealing everyday, but the price hurts a bit. Hopefully you get your issues worked out. Good luck man.
      1. Terry@BMS's Avatar
        Terry@BMS -
        Click here to enlarge Originally Posted by GeorgiaTech335Coupe Click here to enlarge
        Something else isn't right with my car. FP voltage is all over the place, bank 1 AFR and STFt are all over the place. I can feel the car making weird hiccups during the pull. This really sucks. I'm beginning to lose my patience trying fix this car.
        Are you able to monitor low fuel pressure in addition to high fuel pressure? Do you have the upgraded in tank pump yet?
      1. GeorgiaTech335Coupe's Avatar
        GeorgiaTech335Coupe -
        Click here to enlarge Originally Posted by Terry@BMS Click here to enlarge
        Are you able to monitor low fuel pressure in addition to high fuel pressure? Do you have the upgraded in tank pump yet?
        Stock fuel system. This is the first time I've seen the car run like this.
      1. 654's Avatar
        654 -
        Click here to enlarge Originally Posted by GeorgiaTech335Coupe Click here to enlarge
        Stock fuel system. This is the first time I've seen the car run like this.
        Just upgrade your LPFP. Easy and cheap fix. E85 Walbro is $179.
      1. dzenno@PTF's Avatar
        dzenno@PTF -
        Ah sucks man. This is why I always tell people to get or borrow a vbox and do some runs on closed roads to make sure their cars are running strong before hitting the strip. This way you find any issues and address them on time and then just hit the strip to optimize traction for launches and grab those slips.
      1. Terry@BMS's Avatar
        Terry@BMS -
        Click here to enlarge Originally Posted by GeorgiaTech335Coupe Click here to enlarge
        Stock fuel system. This is the first time I've seen the car run like this.
        What fuel? If octane is there you could lean it out to take some stress off the fuel system.
      1. GeorgiaTech335Coupe's Avatar
        GeorgiaTech335Coupe -
        Click here to enlarge Originally Posted by dzenno@ProTUNING Freaks Click here to enlarge
        Ah sucks man. This is why I always tell people to get or borrow a vbox and do some runs on closed roads to make sure their cars are running strong before hitting the strip. This way you find any issues and address them on time and then just hit the strip to optimize traction for launches and grab those slips.
        I have a vbox, but just got the clutch broken in last night so didn't have time to test. Plus I was already committed to this. It's always something with this car.
      1. GeorgiaTech335Coupe's Avatar
        GeorgiaTech335Coupe -
        I'm gonna call it a day. Something isn't right with the car. Sorry I couldn't get a good run in. Hopefully I can figure out what it is and get some vbox 1/4 and 60-130 in this week.
      1. dzenno@PTF's Avatar
        dzenno@PTF -
        Ya definitely get it dialed in with the vbox first. Drag strip action doesn't work out well most times even when the car is 100%. Applaud your efforts and looking forward to some vbox action. At least the car didn't misfire on bank2 anymore..
      1. GetSomeE92's Avatar
        GetSomeE92 -
        That sucks, man. Seems like you have yet to get a chance to enjoy your car to its full potential. Best of luck getting the new issues resolved.
      1. GeorgiaTech335Coupe's Avatar
        GeorgiaTech335Coupe -
        Click here to enlarge Originally Posted by GetSomeE92 Click here to enlarge
        That sucks, man. Seems like you have yet to get a chance to enjoy your car to its full potential. Best of luck getting the new issues resolved.
        Thanks. Jan 27, this car better be up to par or it's going off the side of a cliff.

        Ive spent so much money on injectors coils and plugs it's ridiculous. 20 injectors, about as many coils and 4 sets of plugs. I just want the damn car to run flawlessly for just a month. Is that too much to ask?